POJ 2486 Apple Tree

好抽象的树形DP。。。。。。。。。

Apple Tree
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6411Accepted: 2097

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input 
Each test case contains three parts. 
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200) 
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i. 
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent. 
Input will be ended by the end of file. 

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1 
0 11
1 2
3 2
0 1 2
1 2

1 3Sample Output

11
2

Source

POJ Contest,Author:magicpig@ZSU



#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;

vector<int> g[200];
int N,K,valu[200],dp[2][200][300];
bool vis[200];

void Tree_Dp(int s)
{
    vis[s]=true;
    for(int i=0;i<=K;i++)
        dp[0][s]=dp[1][s]=valu[s];
    for(int i=0;i<g[s].size();i++)
    {
        int t=g[s];
        if(vis[t]) continue;
        Tree_Dp(t);
        for(int j=K;j>=0;j--)
        {
            for(int k=0;k<=j;k++)
            {
                dp[0][s][j+2]=max(dp[0][s][j+2],dp[0][t][k]+dp[0][s][j-k]);
                dp[1][s][j+2]=max(dp[1][s][j+2],dp[0][t][k]+dp[1][s][j-k]);
                dp[1][s][j+1]=max(dp[1][s][j+1],dp[1][t][k]+dp[0][s][j-k]);
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&N,&K)!=EOF)
    {
        for(int i=1;i<=N;i++)
        {
            scanf("%d",valu+i);
            g.clear();
        }
        for(int i=0;i<N-1;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            g[a].push_back(b);
            g.push_back(a);
        }
        memset(vis,false,sizeof(vis));
        memset(dp,0,sizeof(dp));
        Tree_Dp(1);
        printf("%d ",max(dp[1][1][K],dp[0][1][K]));
    }
    return 0;
}
* This source code was highlighted by YcdoiT. ( style: Codeblocks )

原文地址:https://www.cnblogs.com/CKboss/p/3350822.html