PAT Radix[二分][进制转换][难]

1010 Radix (25)(25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:\ N1 N2 tag radix\ Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

//感觉这道题就整个很难读懂。

//N1 N2 tag radix  

//如果tag是1的话,那么radix就是N1的基数;如果tag是2的话,那么radix就是N2的基数。radix的取值范围是0-35.也就是最多是35进制。

//我的想法是先将tag所指的数转成10进制,然后找到另一个数digit最大的,如果当前2进制已经>另一个,那么就impossible;否则就增大;就是很普通的想法。不会想到使用二分法,就是看到题解二分法之后也没想到二分法是如何使用的。

代码来自:https://www.liuchuo.net/archives/2458

#include <iostream>
#include <cctype>//isdigit函数,从来没见过这个函数,厉害了。
#include <algorithm>
#include <cmath>
#include<string>
#include<stdio.h>
using namespace std;
long long convert(string n, long long radix) {
    //
    long long sum = 0;
    int index = 0, temp = 0;
//    for (auto it = n.rbegin(); it != n.rend(); it++) {//isdigit需要配合这样的for循环使用。
//        temp = isdigit(*it) ? *it - '0' : *it - 'a' + 10;
//        sum += temp * pow(radix, index++);
//    }
    int len=n.size();//也可以这样将radix进制转化为10进制。
    for(int i=0;i<len;i++){
        if(n[i]>='0'&&n[i]<='9')temp=n[i]-'0';
        else temp=n[i]-'a'+10;
        sum=sum*radix+temp;
    }
    return sum;
}
long long find_radix(string n, long long num) {//num是10进制的数
    char it = *max_element(n.begin(), n.end());//找出最大的元素。
    //进制数最小是最大元素+1
    //如n=s9jik;则low=29,
    //若n="10",那么进制就会取到num.!!
    long long low = (isdigit(it) ? it - '0': it - 'a' + 10) + 1;
    long long high = max(num, low);
    while (low <= high) {
        long long mid = (low + high) / 2;
        long long t = convert(n, mid);
        if (t < 0 || t > num) high = mid - 1;
        else if (t == num) return mid;
        else low = mid + 1;
    }
    return -1;
}
int main() {
    string n1, n2;
    long long tag = 0, radix = 0, result_radix;
    cin >> n1 >> n2 >> tag >> radix;
    result_radix = tag == 1 ? find_radix(n2, convert(n1, radix)) : find_radix(n1, convert(n2, radix));
    if (result_radix != -1) {
        printf("%lld", result_radix);
    } else {
        printf("Impossible");
    }
    return 0;
}

1.使用二分法,low很好确定,high是另一个数的10进制数;(没想到进制可以这么大)很厉害。

2.radix制如何转换成10进制。

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9340553.html