PAT 1024 Palindromic Number[难]

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10^) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
题目大意就是:给出一个大数,并将其反转,在有限次k次相加内,若结果是回文数,那么就输出并且输出计算次数;否则就直接输出计算k次的结果。
注意到n可能会非常大,10的10次方,而且要进行k次(最多100次),所以用long long不可以了,用string来做大数运算,并且string有reverse函数。
还有主函数中的逻辑判断问题,因为一个数如果是回文数,那么运算结果肯定也是回文数,只要判断一个数反转后是否等于自身,如果相等,那么
就已经找到回文数,就break即可。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<algorithm>
using namespace std;
//
string add(string s1,string s2){
    long long  len=s1.size();
    int a,b=0;
    for(int i=0;i<len;i++){
        if(b==0)
            a=(s1[i]-'0')+(s2[i]-'0');
        else{
            a=(s1[i]-'0')+(s2[i]-'0')+1;
            b=0;
        }
        if(a>=10){
            b=1;
            a%=10;
        }
        s2[i]=a+'0';
    }
    if(b==1){
        s2=s2+'1';
    }
    reverse(s2.begin(),s2.end());
    return s2;
}
bool isH(string s){
    long long  len=s.size();
    long long  f=len/2;
    bool flag=true;
    for(int i=0;i<f;i++)
        if(s[i]!=s[len-i-1]){
            flag=false;break;
        }
    return flag;
}
int main()
{
   string s;
   int k;
   cin>>s>>k;
   string s2;
   int n=0;
   bool flag=false;
   while(n<k){
        s2=s;
        reverse(s.begin(),s.end());
        if(s2==s){
            break;
        }else{
            s=add(s,s2);
            n++;
        }
   }
   cout<<s<<'\n'<<n;
   return 0;
}
 
原文地址:https://www.cnblogs.com/BlueBlueSea/p/9277237.html