ACM题目————A Knight's Journey

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4


直接DFS就好,只是要记住路径:

#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;
int dx[]={-1, 1, -2, 2, -2, 2, -1, 1}, dy[] = {-2, -2, -1, -1, 1, 1, 2, 2};
int path[30][30], vis[30][30], p, q, cnt;
bool flag;

void DFS(int r, int c, int sp)
{
    path[sp][0] = r ;
    path[sp][1] = c ;
    if(sp == p*q )
    {
        flag = 1 ;
        return ;
    }
    for(int i=0; i<8; i++)
    {
        int x = r + dx[i] ;
        int y = c + dy[i] ;
        if(x>=1 && x<=p && y>=1 && y<=q && !vis[x][y] && !flag)
        {
            vis[x][y] = 1 ;
            DFS(x,y,sp+1);
            vis[x][y] = 0 ;
        }
    }
}

int main()
{
    int n, k;
    cin >> n ;
    for(k=1; k<=n; k++)
    {
        flag = 0 ;
        cin >> p >> q ;
        memset(vis,0,sizeof(vis));
        vis[1][1] = 1;
        DFS(1,1,1);
        cout << "Scenario #" << k << ":" << endl ;
        if(flag)
        {
            for(int i=1; i<=p*q; i++)
                printf("%c%d",path[i][1]-1+'A',path[i][0]);
        }
        else cout << "impossible" ;
        cout << endl ;
        if(k!=n) cout << endl ;
    }

    return 0;
}


低调做人,高调做事。
原文地址:https://www.cnblogs.com/Asimple/p/5483665.html