PAT-1126. Eulerian Path (25)

1126. Eulerian Path (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian

提交代码

这道题看起来简单,但是有一个坑就是It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit。所给图必须是一个连通图,首先要dfs判断联通。

#include <bits/stdc++.h>

using namespace std;

int N, M;
int a[505];
vector<int> edge[505];

int CNT = 0;
int flag[505];

void dfs(int x) {
    flag[x] = 1;
    CNT++;
    //cout<< CNT<< endl;
    for(int i = 0; i < edge[x].size(); i++) {
        if(flag[edge[x][i]] == 0) {
            dfs(edge[x][i]);
        }
    }
}

int main()
{
    cin>> N>> M;
    int x, y;
    for(int i = 0; i < M; i++) {
        scanf("%d%d", &x, &y);
        a[x]++;
        a[y]++;
        edge[x].push_back(y);
        edge[y].push_back(x);
    }
    int cnt = 0;
    for(int i = 1; i <= N; i++) {
        if(i != 1) printf(" ");
        printf("%d", a[i]);
        if(a[i]%2 == 1) {
            cnt++;
        }
    }
    cout<< endl;
    dfs(1);
    if(CNT != N) {
        cout<< "Non-Eulerian";
        return 0;
    }
    if(cnt == 0) {
        cout<< "Eulerian";
    }
    else if(cnt == 2) {
        cout<< "Semi-Eulerian";
    }
    else {
        cout<< "Non-Eulerian";
    }
    return 0;
}
原文地址:https://www.cnblogs.com/ACMessi/p/8528246.html