PAT 1029. Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17

Sample Output
13

分析
已知两个有序数列了,只需用两个指针去找到(sum-1)/2的中间值,比较两个指针所指的值大小,小的就++。

#include<iostream>
#include<vector>
using namespace std;
int main(){
    int n,sum=0,m,cnt=0;
    cin>>n;
    sum+=n;
    vector<long int> v1(n);
    for(int i=0;i<n;i++)
        cin>>v1[i];
    cin>>n;
    sum+=n;
    vector<long int> v2(n);
    for(int i=0;i<n;i++)
        cin>>v2[i];
    auto t1=v1.begin(),t2=v2.begin();
    for(int i=0;i<(sum-1)/2;i++){
    	 if(*t1<*t2&&t1!=v1.end()) t1++;
         else if(*t1>=*t2&&t2!=v2.end()) t2++;
         else if(t1==v1.end()) t2++;
         else if(t2==v2.end()) t1++;
	}
	if(t1==v1.end()) cout<<*t2;
	else if(t2==v2.end()) cout<<*t1;
	else 
        cout<<(*t1<*t2?*t1:*t2);
    return 0;
}
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8289142.html