PAT 1012. The Best Rank

The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

分析

只想说90 80 80 80 70的排名是1 2 2 2 5;我是直接利用multimap利用它自己按key排序做的;(map不行)

代码如下

#include<iostream>
#include<map>
#include<math.h>
using namespace std;
struct grade{
	char c;
	int rank=20000;
};
map<string,grade> mapp; // 储存rank信息的
void getrank_ch(multimap<double,string> map_ch,char ch){
	int tag=1,lastrank=-1,cnt=1;
	for(auto b=map_ch.rbegin();b!=map_ch.rend();b++,cnt++){
		if(lastrank!=b->first){
		tag=cnt; lastrank=b->first;	
		} 
		if(tag<mapp[b->second].rank){
			mapp[b->second].rank=tag;
			mapp[b->second].c=ch;
		} 
	}
}
int main(){
	int N,M,e,c,m;
	multimap<double,string> map_e,map_a,map_c,map_m; // 利用这些multimap自动排序
	cin>>N>>M;
	string id;
	for(int i=0;i<N;i++){
	cin>>id>>c>>m>>e;
	map_c.insert({c,id}); map_m.insert({m,id});
	map_e.insert({e,id}); map_a.insert({(e+c+m)/3.0,id});
	}
	getrank_ch(map_a,'A'); 
	getrank_ch(map_c,'C');
	getrank_ch(map_m,'M'); 
	getrank_ch(map_e,'E');
	for(int i=0;i<M;i++){
		cin>>id;
		if(mapp[id].rank==20000) cout<<"N/A"<<endl;
		else cout<<mapp[id].rank<<" "<<mapp[id].c<<endl;
	}	
}
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8196239.html