PAT 1020. 月饼

PAT 1020. 月饼 (25)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

这道题很简单,就是把各个种类的月饼按每万吨利润排个序,然后去处理就行了。其中我为了去回顾一下类的用法呢,特地不用struct而去采用class,果然许多基础的class的知识###都忘光了。唉o︶︿︶o唉,绝望了,感觉不会再爱了,c++primer永远是我的朋友了┑( ̄▽  ̄)┍ 。

当然这道题有个地方 卡了我一下,就是分母不能为零。〒_〒

#include<iostream>
#include<vector>
#include<algorithm>
#include<iomanip>
using namespace std;
struct mooncake{
		double storage;
		double profit;
		double profit_per;                                                      
};
bool comp(const mooncake& m1,const mooncake& m2){return m1.profit_per<m2.profit_per;}                
int main(){
	double kinds,max_demand;
	double Profit=0;
	cin>>kinds>>max_demand;
	vector<mooncake> mooncakes;
    mooncakes.resize(kinds);
    for(int i=0;i<kinds;i++){cin>>mooncakes[i].storage;}
    for(int i=0;i<kinds;i++)
	{
	cin>>mooncakes[i].profit; 
	if(mooncakes[i].storage==0) //此处有坑,慎跳→_→
	mooncakes[i].profit_per=0;
	else
	mooncakes[i].profit_per=mooncakes[i].profit/mooncakes[i].storage;
	}
	sort(mooncakes.begin(),mooncakes.end(),comp);
	auto e=mooncakes.end()-1;
	while(e>=mooncakes.begin()){
		if(e->storage>=max_demand){Profit+=max_demand*e->profit_per; break;}
		else {Profit+=e->storage*e->profit_per; max_demand-=e->storage; e--;}
	}
	cout<<fixed<<setprecision(2)<<Profit<<endl;
	return 0;	
} 
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8059553.html