hdu 1002 A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2 1 2 112233445566778899 998877665544332211
 
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
Author
Ignatius.L
 
Recommend
We have carefully selected several similar problems for you:  1004 1003 1008 1005 1089 
水题,按位加,做好末尾判断,最后输出一个回车。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define inf 0x3f3f3f3f
#define MAX 1000
using namespace std;

int n;
char s[MAX + 1],t[MAX + 1];
char ans[MAX + 2];
int main() {
    scanf("%d",&n);
    for(int i = 0;i < n;i ++) {
        if(i) putchar('
');
        scanf("%s%s",s,t);
        int d = 0,slen = strlen(s),tlen = strlen(t);
        int maxlen = max(slen,tlen);
        for(int j = 0;j < maxlen;j ++) {
            if(j < slen)d += s[slen - j - 1] - '0';
            if(j < tlen)d += t[tlen - j - 1] - '0';
            ans[j] = d % 10 + '0';
            d /= 10;
        }
        if(d) {
            ans[maxlen] = d + '0';
            ans[maxlen + 1] = '';
        }
        else ans[maxlen] = '';
        reverse(ans,ans + strlen(ans));
        printf("Case %d:
%s + %s = %s
",i + 1,s,t,ans);
    }
}
原文地址:https://www.cnblogs.com/8023spz/p/9748538.html