PAT 解题报告 1004. Counting Leaves (30)

1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1


题目描述:

统计一颗树每一层的leaf数量。

算法分析:

思路1:BFS

本质就是lever order traversal, 可以用bfs遍历,然后每一层统计叶子数。

思路2:DFS

可以使用邻接矩阵的方式定义树结构。然后使用 dfs 遍历树的节点,并记录每层的叶子节点数量。 可以看到,时间空间的 trade-off 不仅仅是性能上的提升,也会影响带代码实现的复杂程度。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>

using namespace std;

#define MX 101

int mp[MX][MX];
queue<int> que;
int n,m;

int bfs(int s) {
    int flag = 1;
    for (int i=1; i<=n; i++) {
        if (mp[s][i] == 1) {
            que.push(i);
            flag = 0;
        }
    }
    return flag;
}

void actbfs() {
    que.push(1);
    que.push(0);
    int cnt = 0;
    while (!que.empty()) {
        int s = que.front();
        que.pop();
        if (s == 0) {
            if (que.empty()) {
                printf("%d", cnt);
                break;
            }
            else {
                que.push(0);
                printf("%d ", cnt);
                cnt = 0;
            }
        }
        else {
            int flag = bfs(s);
            cnt += flag;
        }
    }
}

int main()
{
    scanf("%d%d", &n,&m);
    memset(mp, 0, sizeof(mp));
    for (int i=0; i<m; i++) {
        int id,k;
        scanf("%d%d", &id,&k);
        for (int j=0; j<k; j++) {
            int chi;
            scanf("%d", &chi);
            mp[id][chi] = 1;
        }
    }

    actbfs();

    return 0;
}


原文地址:https://www.cnblogs.com/549294286/p/3571432.html