hdu 1907 John

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1312    Accepted Submission(s): 683


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 
Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 
Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 
Sample Input
2 3 3 5 1 1 1
 
Sample Output
John Brother
 
Source
 
Recommend
lcy

//博弈?呵呵、感觉和2进制好有关系的东西、是门大学问

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
    int T;
    int n,m;
    scanf("%d",&T);
    int sum,num,t;
    while(T--)
    {
        scanf("%d",&n);
        sum=num=0;
        m=n;
        while(m--)
        {
            scanf("%d",&t);
            if(t==1) num++;
            sum^=t;
        }
       // printf("%d\n",num);
        if(num==n)
        {
            if(n%2)
              printf("Brother\n");
            else
              printf("John\n");
        }
        else
        {
            if(sum==0)
              printf("Brother\n");
            else
              printf("John\n");
        }
    }
    return 0;
}

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
    int T;
    int n,m;
    scanf("%d",&T);
    int sum,num,t;
    while(T--)
    {
        scanf("%d",&n);
        sum=num=0;
        m=n;
        while(m--)
        {
            scanf("%d",&t);
            if(t==1) num++;
            sum^=t;
        }
       // printf("%d\n",num);
        if(num==n)
        {
            if(n%2)
              printf("Brother\n");
            else
              printf("John\n");
        }
        else
        {
            if(sum==0)
              printf("Brother\n");
            else
              printf("John\n");
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/372465774y/p/2610665.html