HDU 2147 kiki's game

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/1000 K (Java/Others)
Total Submission(s): 3365    Accepted Submission(s): 1952


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 
Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 
Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 
Sample Input
5 3
5 4
6 6
0 0
 
Sample Output
What a pity!
Wonderful!
Wonderful!
//这种题目想明白了就简单了
//该题只要有偶数格子、猪脚凑偶路线就可以,,凑不成就输了
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m),n||m)
    {
        if(n%2&&m%2)
          printf("What a pity!\n");
         else
         printf("Wonderful!\n");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/372465774y/p/2585681.html