POJ 1083 Moving Tables

Moving Tables
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20479   Accepted: 6717

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

Source

这题就是给你N个区间,求出最多不想交的区间数

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct node
{
    int s,t;
};
node gd[203];
node re[203];
bool cmp(const node &a,const node &b)
{
    if(a.s==b.s)
     return a.t<b.t;
    return a.s<b.s;
}
int main()
{
    int T,n;
    int s,t;
    int i,j,k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&s,&t);
            if(s%2==0) s--;//奇偶相差一算是一个区间段的,应为是对称着的
            if(t%2==0) t--;
            gd[i].s=s<t?s:t;
            gd[i].t=s>t?s:t;
        }
      sort(gd,gd+n,cmp);
      memset(re,0,sizeof(re));
      for(k=i=0;i<n;i++)
      {
          j=0;
         while(gd[i].s<=re[j].t)//这是因为奇偶算是一个区间段,所以这里才有等号
         {
             j++;
         }
         re[j]=gd[i];
         if(j>k)
          k=j;
      }
      k++;
      printf("%d\n",k*10);
    }
    return 0;
}

原文地址:https://www.cnblogs.com/372465774y/p/2567018.html