hdu--2035--人见人爱A^B--快速幂

人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 75912    Accepted Submission(s): 50296

Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 
Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 
Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 
Sample Input
2 3 12 6 6789 10000 0 0
 
Sample Output
8 984 1

快速幂

#include <bits/stdc++.h> 

using namespace std;

int FastPow(int a,int n) {
    int base = a % 1000;
    int res = 1;
    while(n) {
        if(n & 1)
            res = res * base % 1000;
        base = base * base % 1000;
        n >>= 1;
    }
    return res;
}

int main()
{    
    int a,b;
    int ans = 1,base = 1;
    while(~scanf("%d %d",&a,&b) && (a || b)) {
        printf("%d",FastPow(a,b));
        putchar(10);
    }
    return 0;
}

2021-02-10

原文地址:https://www.cnblogs.com/2015-16/p/14395583.html