poj1328贪心 雷达,陆地,岛屿问题

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 60381   Accepted: 13610

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

 
 
 
题意:有一个坐标轴 在X轴上方是海 下方是陆地 X轴是海岸线,海上有N个小岛,现在要在海岸线上安装雷达,

雷达的覆盖范围是一个以R为半径的圆,请用最少的雷达覆盖所有的小岛;当无法覆盖时 输出-1

 

思路:算出 每个小岛能被覆盖的雷达的圆心,即以小岛为圆心 R为半径 作圆,该圆与X轴的交点:

左交点为x-sqrt(R*R-y*y); 右交点为x+sqrt(R*R-y*y);

按照 左交点 排序,如果i点的左交点在 当前雷达的右边 则需安装一个新雷达,更新雷达

否则 如果 i点的右交点也在当前雷达的左边 则把当前雷达的圆心更新为该点的右交点;

代码

::

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
 struct node{
    double x;
    double y;
 }que[1005];
 bool cmp(struct node a,struct node b){
   return a.x<b.x;
 }
int main(){
   int n;
   double d;
   int count=0;
   while(scanf("%d%lf",&n,&d)!=EOF){
       int sum;
       if(n==0&&d==0)
       break;
       int flag=0;
       count++;
      for(int i=0;i<n;i++){
          double a,b;
          scanf("%lf%lf",&a,&b);
          que[i].x=a-sqrt(d*d-b*b);
          que[i].y=a+sqrt(d*d-b*b);
          if(b>d||d<=0||b<0)
          flag=1;

      }
      if(!flag){
      sort(que,que+n,cmp);
      double temp;
      temp=que[0].y;
       sum=1;
      for(int i=1;i<n;i++){
          if(que[i].x>temp){
              sum++;
              temp=que[i].y;
          }
          else if(que[i].y<temp){
             temp=que[i].y;
          }
      }
      }
      if(flag)
      printf("Case %d: -1 ",count);
      else
      printf("Case %d: %d ",count,sum);
   }
   return 0;
}

 
 
 
 
 
 
 
 
 
原文地址:https://www.cnblogs.com/13224ACMer/p/4617177.html