PAT1027:Colors In Mars

1027. Colors in Mars (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

思路
很简单的10进制数转换为13进制数问题
代码
#include<iostream>
using namespace std;
char a[14] = "0123456789ABC";
int main()
{
  int colors[3];
  while(cin >> colors[0] >> colors[1] >> colors[2])
  {
    cout <<"#";
    for(int i = 0;i < 3;i++)
    {
        cout << a[colors[i]/13] << a[colors[i] % 13];
    }
    cout << endl;
  }
}
 
原文地址:https://www.cnblogs.com/0kk470/p/Pat.html