poj_2485_mst

                       Highways
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3



  这道题就是给出了n个村的坐标,然后给出了m条路,表示已经修好的路,不过要求的不是求最小权值,而是问,修建哪些路最优,输出需要修的路。
  既然这道题要求的是输出需要修建的路,只需要在把一个点从v拿出加到u里的同时,记录下这条边就OK了,所以,可以再维护一个数组,pre[MAXN],
因为cost[i][j]表示i和j之间的权值为cost[i][j],所以连接j的时候更新pre[j],即:
pre[i]表示j这个点的前导节点,在扫描u,v之间的最小边的同时更新pre[i].
  这道题不是直接给出了点,而是给出了点的坐标,其实只需要定义一个Point,用来存储点的坐标,point[i]的坐标为point[i].x和point[i].y
  另外,输出的顺序可以不一样,我开始就是因为顺序不一样不敢交。

#include<cstdio>
#include<cstring>
#include<cmath>
const double INF=999999999.9;//注意这里是double,我开始逗比写成了int

const int MAXN=755;
struct Point
{
  double x,y;
}point[MAXN];
double cost[MAXN][MAXN];
bool vis[MAXN];
double lowc[MAXN];
int pre[MAXN];
int tot;//记得初始化
double get_dis(int i,int j)
{
  return sqrt((point[i].x-point[j].x)*(point[i].x-point[j].x)+(point[i].y-point[j].y)*(point[i].y-point[j].y));

  //这里其实可以不开方
}
int prim(int n)
{
  memset(vis,false,sizeof(vis));
  memset(pre,0,sizeof(pre));//初始化
  vis[1]=true;
  double ans=0.0;//double double double 
  for(int i=2;i<=n;i++)
  {
    lowc[i]=cost[1][i];
    pre[i]=1;//点i的前导节点是1
  }
  for(int i=2;i<=n;i++)
  {
    double minc=INF;
    int p=-1;
    for(int j=1;j<=n;j++)
      if(!vis[j]&&lowc[j]<minc)
      {
        minc=lowc[j];
        p=j;
      }
    if(minc==INF)
      return -1;
    ans+=minc;
    vis[p]=true;
    if(cost[p][pre[p]]!=0||cost[pre[p]][p]!=0)
    {
      printf("%d %d ",pre[p],p);//注意空格
    }
    for(int j=1;j<=n;j++)
      if(!vis[j]&&cost[p][j]<lowc[j])
      {
        lowc[j]=cost[p][j];
        pre[j]=p;//更新
      }
  }
  return ans;
}
int main()
{
  int n;
  while(scanf("%d",&n)!=EOF)
  {
    for(int i=1;i<=n;i++)
    {
      scanf("%lf%lf",&point[i].x,&point[i].y);//double型输入用lf,因为这个也逗比了很久
    }
    for(int i=1;i<=n;i++)
    {
      lowc[i]=INF;//初始化

      for(int j=1;j<=n;j++)
      {
        cost[i][j]=get_dis(i,j);
      }
    }
    int m;
    int u,v;
    scanf("%d",&m);
    for(int i=1;i<=m;i++)
    {
      scanf("%d%d",&u,&v);
      cost[u][v]=cost[v][u]=0;
    }
    double ans=prim(n);
    if(ans==0.0)
    printf(" ");
  }
  return 0;
}









原文地址:https://www.cnblogs.com/-maybe/p/4233749.html