Cow exhibiton (01背包变形)

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not allowed.

这道题的关键有两点:一是将smartness看作花费、将funness看作价值,从而转化为01背包;二是对负值的处理,引入一个shift来表示“0”,这里的shift一定要大于每一个smartness的绝对值,另外在遍历cost[]的时候如果cost[i]>0,显然时从开的数组的最大值maxm 开始往下减,如果cost[i]<0,则是从0(是0,不是shift)开始往上增加。大于0的情况容易想到,小于0的情况比较费解,需要仔细思考。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 201005;
const int inf = 99999;
int d[maxn];
int main()
{
    int n,a,b;
    while(cin>>n){
        for(int i=0;i<maxn;i++)
            d[i]=-inf;
        d[100000]=0;
        for(int i=0;i<n;i++){
            cin>>a>>b;
            if(a<0&&b<0)
                continue;
            else if(a>0)
                for(int k=200000;k>=a;k--)
                    d[k]=max(d[k],d[k-a]+b);
            else
                for(int k=a;k<=200000;k++)
                    d[k]=max(d[k],d[k-a]+b);
        }
        int maxd = -inf;
        for(int i=200000;i>=100000;i--){
            if(d[i]>=0)
                maxd = max(maxd,d[i]+i-100000);
        }
        if(maxd<0)
            cout<<"0"<<endl;
        else
            cout<<maxd<<endl;
    }
}

  

原文地址:https://www.cnblogs.com/zzzying/p/7395045.html