还是畅通工程

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。 

Input测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。 
当N为0时,输入结束,该用例不被处理。 
Output对每个测试用例,在1行里输出最小的公路总长度。 
Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5


        
 
Huge input, scanf is recommended.

还是用并查集的思想,不过是用一个结构体存储数据,然后长度从小到大排序,这样每次判断都是从最小的开始在加上并查集的判断,ans的值就是最小的
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10005;
int f[maxn],m;
struct node{
    int v1,v2,l;
}n[maxn];
bool cmp(node n1,node n2){
    return n1.l<n2.l;
}
void init(int t){
    for(int i = 0; i <= t; i++)
        f[i] = i;
}
int check(int x){
    return f[x] == x ? x : f[x] = check(f[x]);
}
void merge(int x,int y){
    int t1 = check(x);
    int t2 = check(y);
    if(t1 != t2){
        f[t2] =t1;
    }
    return;
}
int account(){
    sort(n,n+m,cmp);
    int ans = 0;
    for(int i = 0; i < m; i++){
        if(check(n[i].v1) != check(n[i].v2)){
            merge(n[i].v1,n[i].v2);
            ans += n[i].l;
        }
    }
    return ans;
}
int main()
{
    std::ios::sync_with_stdio(false);
    int t;
    int v1,v2,l;
    while(cin >> t){
        if(t == 0)
            break;
        init(t);
        m = t * (t-1) / 2;
        for(int i = 0; i < m; i++)
            cin>>n[i].v1>>n[i].v2>>n[i].l;
        cout<<account()<<endl;
    }
    return 0;
}

  

 
原文地址:https://www.cnblogs.com/zzzying/p/7297742.html