The Perfect Stall

The Perfect Stall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 25497   Accepted: 11339

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

Source

USACO 40
【解析】:
二分图+匈牙利算法。
一个牛栏对应一头牛 求最大匹配。
【code】
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 201
int map[N][N],match[N],vis[N];
int cnt,n,m,num,k;
bool path(int x)
{
    for(int i=1;i<=m;i++)
    {
        if(map[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(match[i]==-1||path(match[i]))
            {
                match[i]=x;//注意是这个牛栏匹配这头牛,一开始牛匹配牛栏了。 
                return 1;
            }        
        }
    }
    return 0;
}
int main()
{
    while(cin>>n>>m)
    {
        memset(map,0,sizeof(map));
        memset(match,-1,sizeof(match));
        cnt=0;
        for(int i=1;i<=n;i++)
        {
            cin>>num;
            for(int j=1;j<=num;j++)
            {
                cin>>k;
                map[i][k]=1;
            }
        }
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(path(i))
            cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
 } 

注意match是谁匹配谁。而且这个题scanf和printf超时。

 
原文地址:https://www.cnblogs.com/zzyh/p/6837237.html