hdu 1025LIS思路同1257 二分求LIS

题目:

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24446    Accepted Submission(s): 6968


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 
Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 
Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 
Sample Input
2 1 2 2 1 3 1 2 2 3 3 1
 
Sample Output
Case 1: My king, at most 1 road can be built.
Case 2: My king, at most 2 roads can be built.
 
大意:输入n 表示n对关系
接着n行,每行a  b   表示a村与b村建立了关系
一个贫穷村庄与一个富裕村建立关系(保证不重复且一个富村只能与一个贫建立)
保证路线不重叠交叉下求最多建立几条道路;
仔细想想还是lis,与1257类似的思想,
输入 a,b 存入数组中a[a]=b,因为村庄从1到n遍历一遍所以输入完之后就是一个长度为n的数组,求最多线路不就是求lis么(即保证数组升序即可)
此时因为maxn过大,采用O(NlogN),用到二分搜索算法
代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=500005;
const int inf=99999999;
int p[maxn],dp[maxn];
int main()
{
    int n,i,m=0;
    while (scanf("%d",&n)!=EOF){int q,r;m++;
        for (i=0;i<n;i++)
        scanf("%d%d",&q,&r),p[q-1]=r;
        fill(dp,dp+n,inf);
        
        for(i=0;i<n;i++)
        *lower_bound(dp,dp+n,p[i])=p[i];      //每次更新的过程,由于fill了inf,所以如果当前ta为最大则直接加到数组最后一个!INF的后面

int len=lower_bound(dp,dp+n,inf)-dp; printf("Case %d: ",m); if (len==1) printf("My king, at most 1 road can be built. "); else printf("My king, at most %d roads can be built. ",len); printf(" "); } return 0; }
原文地址:https://www.cnblogs.com/zzqc/p/6398477.html