4 Values whose Sum is 0

Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 30579   Accepted: 9351
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 4010;
int n;
LL A[maxn],B[maxn],C[maxn],D[maxn];
LL AB[maxn*maxn],CD[maxn*maxn];
int main(void)
{
    cin >> n;
    for(int i=0;i<n;i++)
    {
        cin >> A[i]>>B[i]>>C[i]>>D[i];
    }
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            AB[i*n+j]=A[i]+B[j];
            CD[i*n+j]=C[i]+D[j];    
        }    
    } 
    sort(CD,CD+n*n);
    int result = 0;
    for(int i=0;i<n*n;i++)
    {
        result += upper_bound(CD,CD+n*n,-AB[i])-lower_bound(CD,CD+n*n,-AB[i]);
        //cout << result<<endl;
    } 
    cout << result;
    return 0;
} 
原文地址:https://www.cnblogs.com/zuimeiyujianni/p/10031496.html