Trees on the level (二叉链表树)

紫书:P150 uva122

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

picture28

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

给出树的节点以及它的位置,最后要求按照从上至下,从左至右的顺序访问节点,很显然,最后按照bfs来遍历这棵二叉树就好,复杂的在于输入以及树的建立
关于输入:scanf(“%s”)可以排除空格的干扰,sscanf()可以很方便地取出其中的数字,因为它可以把字符串中的某个部分取出然后自动转化成你想要的类型
strcmp()则可以判断输入是否结束
关于树的建立:不要只会递归地先序地建立树,其实树的建立也可以很灵活,还有一个重点,对于树中的节点,有可能在其中做某个标记,那么在初始化分配内存需要附上一个初值
那么就要学会写构造函数
如:
struct node
{
int data;
int vis;
struct node*lchild;
struct node*rchild;
node():vis(0),lchild(NULL),rchild(NULL){}; //这就是构造函数,通过它可以直接定义struct node u=new node();在之后的建树过程减少了叶子节点
} //的左右孩子赋空带来的麻烦,同时也满足vis置为0的要求
//如果某个节点没有孩子节点时,一定要把后置指针置空!!!
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
typedef struct node
{
    int data;
    int vis;
    struct node *lchild;
    struct node *rchild;
    node():vis(0),lchild(NULL),rchild(NULL) {}
}*BItree,bt;

bool faliure;
void AddNode(int v,char* s,BItree root)
{
    int n=strlen(s);
    BItree u=root;
    for(int i=0;i<n;i++)
    {
        if(s[i]=='L')
        {
            if(u->lchild==NULL)
                u->lchild=new node();
            u=u->lchild;
        }
        else if(s[i]=='R')
        {
            if(u->rchild==NULL)
                u->rchild=new node();
            u=u->rchild;
        }
    }
    if(u->vis==1) faliure=true;
    u->vis=1;
    u->data=v;
}

bool bfs(vector<int>& ans,BItree root)
{
    queue<BItree> que;
    ans.clear();
    que.push(root);
    while(!que.empty())
    {
        BItree u=que.front();
        que.pop();
        if(!u->vis) return false;
        ans.push_back(u->data);
        if(u->lchild!=NULL) que.push(u->lchild);
        if(u->rchild!=NULL) que.push(u->rchild);
    }
    return true;
}

char s[1000];
BItree root;
bool input()
{
    faliure=false;
    root=new node();
    while(1)
    {
       if(scanf("%s",s)!=1) return false;
       if(!strcmp(s,"()")) break;
       int v;
       sscanf(&s[1],"%d",&v);
       AddNode(v,strchr(s,',')+1,root);
    }
    return true;
}

int main()
{
    while(input())
    {
    vector<int>ans;
    if(bfs(ans,root)&&!faliure)
    {
        for(int i=0;i<ans.size();i++)
        {
            if(i) cout<<" ";
            cout<<ans[i];
        }
        puts("");
    }
    else cout<<"not complete"<<endl;
    }
    return 0;
}
View Code
原文地址:https://www.cnblogs.com/zsyacm666666/p/5001776.html