集训第五周动态规划 J题 括号匹配

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

求括号能够正确匹配的括号个数

dp(i,j)表示区间ij内的正确括号个数

dp(i,j)=max{dp(i+1,j-1)+2 (仅当外层括号匹配),dp(i,k)+dp(k,j)(进行内层括号检查)}

#include"iostream"
#include"cstring"
using namespace std;

int dp[110][110];
string a;

void Work()
{
    int len=a.length();
    //cout<<len<<endl;
    memset(dp,0,sizeof(dp));
    int ans=0;
    for(int i=0;i<len;i++)
    {
        for(int j=0,k=i;k<len;k++,j++)
        {
            if((a[j]=='('&&a[k]==')')||(a[j]=='['&&a[k]==']'))
            dp[j][k]=dp[j+1][k-1]+2;
            for(int t=j+1;t<k;t++)
            if(dp[j][t]+dp[t][k]>dp[j][k])
            dp[j][k]=dp[j][t]+dp[t][k];
            if(dp[j][k]>ans) ans=dp[j][k];
        }
    }
    cout<<ans<<endl;
}

int main()
{
    while(cin>>a)
    {
     if(a=="end") break;
     Work();
    }
    return 0;
}
O(O_O)O
原文地址:https://www.cnblogs.com/zsyacm666666/p/4725660.html