集训第五周动态规划 C题 编辑距离

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration
A G T A A G T * A G G C 
| | | | | | |
A G T * C * T G A C G C
Deletion: * in the bottom line 
Insertion: * in the top line 
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C 
| | | | | | |
A G T C T G * A C G C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

经典的LIS变种,编辑距离
很显然这道题使用一般的方法是做不出来的,因为这道题要求输出的操作数最少,每一步的方法都应该最优。
所以DP
状态表示:dp[i][j]表示两个字符串
最优子结构:dp[i][j]表示从a[i]到b[j]完全匹配的最小操作数
状态转移方程:1.dp[i][j]=dp[i-1][j-1] (a[i]=b[j]) //相等无需变化,因此操作数也不增加
2.dp[i][j]=min{dp[i-1][j]+1,dp[i][j-1]+1,dp[i-1][j-1]+1} (a[i]!=b[j]) //不相等还要考虑替换,插入操作

3.dp[i][0]=i,dp[0][i]=i //这是初始化步骤,这符合规律,因为这种情况下只能执行删除操作,而这也是动态规划往后扩展的基石


#include"iostream"
#include"cstdio"
using namespace std;

const int maxn=1010;

int m,n,len,ans;
char a[maxn],b[maxn];
int dp[1010][1010];

void Work()
{
    len=max(m,n);
    for(int i=0;i<=len;i++)
    {
        dp[i][0]=i;
        dp[0][i]=i;
    }
    for(int i=1;i<=m;i++)
    {
        for(int j=1;j<=n;j++)
        {
            dp[i][j]=min(dp[i-1][j],dp[i][j-1])+1;
            if(a[i]==b[j])
            dp[i][j]=dp[i-1][j-1];
            else
            dp[i][j]=min(dp[i][j],dp[i-1][j-1]+1);
        }
    }
    ans=dp[m][n];
}

void Print()
{
    cout<<ans<<endl;
}

int main()
{
    while(~scanf("%d %s",&m,a+1))
     {
         scanf("%d %s",&n,b+1);
         Work();
         Print();
     }
    return 0;
}
O(OO)O
原文地址:https://www.cnblogs.com/zsyacm666666/p/4723608.html