UVA 1600

Description

Download as PDF
 

A robot has to patrol around a rectangular area which is in a form of mxn grid (m rows and n columns). The rows are labeled from 1 to m. The columns are labeled from 1 to n. A cell (ij) denotes the cell in row i and column j in the grid. At each step, the robot can only move from one cell to an adjacent cell, i.e. from (xy) to (x + 1, y), (xy + 1), (x - 1, y) or (xy - 1). Some of the cells in the grid contain obstacles. In order to move to a cell containing obstacle, the robot has to switch to turbo mode. Therefore, the robot cannot move continuously to more than k cells containing obstacles.

Your task is to write a program to find the shortest path (with the minimum number of cells) from cell (1, 1) to cell (mn). It is assumed that both these cells do not contain obstacles.

Input 

The input consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each data set, the first line contains two positive integer numbers m and n separated by space (1$ le$mn$ le$20). The second line contains an integer number k(0$ le$k$ le$20). The ith line of the next m lines contains n integer aij separated by space (i = 1, 2,..., m;j = 1, 2,...,n). The value of aij is 1 if there is an obstacle on the cell (ij), and is 0 otherwise.

Output 

For each data set, if there exists a way for the robot to reach the cell (mn), write in one line the integer number s, which is the number of moves the robot has to make; -1 otherwise.

Sample Input 

3 
2 5 
0 
0 1 0 0 0 
0 0 0 1 0 
4 6 
1 
0 1 1 0 0 0
0 0 1 0 1 1
0 1 1 1 1 0
0 1 1 1 0 0
2 2 
0 
0 1 
1 0

Sample Output 

7 
10 
-1


思路:这道题相比普通的BFS求最短路径题,还多设置了一个坑,机器人是可以穿越障碍物的!
不过设置好一个变量flag记录穿越障碍物的数量就好
之前wa了好多次,最后发现原来忘了标记穿越障碍物的数量,book不应该只记录两个变量的!

#include"iostream"
#include"cstring"
#include"cstdio"
using namespace std;
struct node
{
int x;
int y;
int flag;
int s;
};

int nex[4][2]={{1,0},{0,1},{-1,0},{0,-1}};

int main()
{
int T;
cin>>T;
while(T--)
{
int n,m,kip;
cin>>n>>m;
cin>>kip;
int a[21][21],book[21][21][21];
memset(a,0,sizeof(a));
memset(book,0,sizeof(book));
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
cin>>a[i][j];

struct node que[420];
for(int kk=0;kk<420;kk++)
{
que[kk].x=0;
que[kk].y=0;
que[kk].flag=0;
que[kk].s=-1;
}
int head,tail;
int i,j,k,startx,starty,p,q,tx,ty;

startx=1;
starty=1;//cout<<kip<<endl;
p=n;
q=m;

head=1;
tail=1;

que[tail].x=startx;
que[tail].y=starty;
que[tail].flag=0;
que[tail].s=0;
tail++;
book[startx][starty][0]=1;
int ff=0;
int f1=0;
while(head<tail)
{


if(que[head].x==p&&que[head].y==q)
{
break;
}

for(k=0;k<=3;k++)
{
tx=que[head].x+nex[k][0];
ty=que[head].y+nex[k][1];
ff=que[head].flag;

if(tx<1||tx>n||ty<1||ty>m)           // 之前曾写错为   if(tx<1||tx>20||ty<1||ty>20)

continue;

if(a[tx][ty]==1) ff++;
else ff=0;

if(ff>kip) continue;

// if(tx==p&&ty==q) {f1=1;break;}

if(book[tx][ty][ff]==0)
{

book[tx][ty][ff]=1;

que[tail].x=tx;
que[tail].y=ty;
que[tail].flag=ff;
que[tail].s=que[head].s+1;
tail++;


}

}
// if(f1==1) {que[head].s=que[head].s+1;break;}

head++;
}

cout<<que[head].s<<endl;
}

return 0;
}

原文地址:https://www.cnblogs.com/zsyacm666666/p/4663889.html