PAT 乙级1042 字符统计 (20分)

输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........
 

输出样例:

e 7

思路:通过查表的方法记录并找出频率最高的字母
#include<iostream>
#include<string>
using namespace std;
int main()
{
    int ascii[128] = { 0 };
    string str;
    char ch = '0';
    while (cin >> str)
    {
        /*arry.push_back()*/
        for (unsigned int i=0;i<str.size();i++)
        {
            int index = str[i];
            if (index >= 65 && index <= 90)//大写转换为小写
            {
                index += 32;
                ascii[index]++;
            }
            else ascii[index]++;
        }
        if (getchar()=='
')break;//遇到换行符退出循环
    }
    int maxindex=97,max=ascii[maxindex];//找出频率最高的字母
    for (int i = 98; i <=122; i++)
    {
        if (max < ascii[i])
        {
            max = ascii[i];
            maxindex = i;
        }
    }
    ch = maxindex;
    cout << ch << " " << ascii[maxindex];
    return 0;
}
 
原文地址:https://www.cnblogs.com/zongji/p/13291919.html