25-Fibonacci(矩阵快速幂)

 
 
                                            Fibonacci
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17694   Accepted: 12315

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

 
#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 2;
const int mod = 1e4;

struct mat{
	int f[MAX][MAX];
	mat operator * (const mat x){  //重载矩阵的乘法 
		mat rt;
		for(int i = 0; i < MAX; i++){
			for(int j = 0; j < MAX; j++){
				int ans = 0;
				for(int m = 0; m < MAX; m++){
					ans += (this->f[i][m] * x.f[m][j]) % mod;
					ans %= mod;
				}
				rt.f[i][j] = ans;
			}
		}
		return rt;
	}
}; 

mat quike(mat base, int n){  //与普通快速幂相似,只是用于存结果的其实值不同,这里用的是rt单位矩阵,类似乘法中设的1 
	mat rt;
	memset(rt.f, 0, sizeof(rt.f));
	for(int i = 0; i < MAX; i++)
		rt.f[i][i] = 1;
	while(n){
		if(n & 1)
			rt = rt * base;
		base = base * base;
		n >>= 1;
	}
	return rt;
}

int main(){
	int n;
	mat base;
	for(int i = 0; i < MAX; i++){
		for(int j = 0; j < MAX; j++)
			base.f[i][j] = 1;
	}
	base.f[1][1] = 0;
	while(cin >> n && n != -1){
		mat ans = quike(base, n);
		cout << ans.f[0][1] << endl;	
	}
	return 0;
}

  

原文地址:https://www.cnblogs.com/zhumengdexiaobai/p/8681395.html