sdut 面向对象程序设计上机练习九(对象指针)

面向对象程序设计上机练习九(对象指针)

Time Limit: 1000MS Memory limit: 65536K

题目描写叙述

建立对象数组,内放5个学生数据(学号是字符串类型、成绩是整型)。设立max函数,用指向对象的指针作函数參数,在max函数中找出5个学生中成绩最高者,并输出其学号和成绩。

输入

输入5个学生数据。

输出

输出5个学生中成绩最高者的学号和成绩。

演示样例输入

01 89
02 78
03 56
04 92
05 76

演示样例输出

04 92

来源

#include <iostream>

using namespace std;

class student
{
public:
    char no[100];
    int score;
};

student a[5];

void max(student *&p)
{
    int i;
    int max=a[0].score;
    for(i=1; i<5; i++)
    {
        if(a[i].score > max)
        {
            max=a[i].score;
            p = &a[i];
        }
    }
}

int main()
{
    int i;
    for(i=0; i<5; i++)
        cin>>a[i].no>>a[i].score;
        
    student *p=&a[0];
    max(p);
    
    cout<<p->no<<" "<<p->score<<endl;
    return 0;
}


原文地址:https://www.cnblogs.com/zhchoutai/p/6824422.html