bzoj1754 [Usaco2005 qua]Bull Math

Description

Bulls are so much better at math than the cows. They can multiply huge integers together and get perfectly precise answers ... or so they say. Farmer John wonders if their answers are correct. Help him check the bulls' answers. Read in two positive integers (no more than 40 digits each) and compute their product. Output it as a normal number (with no extra leading zeros). FJ asks that you do this yourself; don't use a special library function for the multiplication. 输入两个数,输出其乘积

Input

* Lines 1..2: Each line contains a single decimal number.

Output

* Line 1: The exact product of the two input lines

Sample Input

11111111111111
1111111111

Sample Output

12345679011110987654321

bzoj水题二连发……高精乘法随便写就行了

#include<cstdio>
char s1[101],s2[101];
int l1,l2,l3;
int a[101],b[101],c[101];
int main()
{
	scanf("%s%s",s1,s2);
	while (s1[l1]>='0'&&s1[l1]<='9')l1++;
	while (s2[l2]>='0'&&s2[l2]<='9')l2++;
	for (int i=1;i<=l1;i++)
	  a[l1-i+1]=s1[i-1]-'0';
	while (!a[l1])l1--;
	for (int i=1;i<=l2;i++)
	  b[l2-i+1]=s2[i-1]-'0';
	while (!b[l2])l2--;
	for (int i=1;i<=l1;i++)
	  for (int j=1;j<=l2;j++)
	    c[i+j-1]+=a[i]*b[j];
	for (int i=1;i<=l1+l2+2;i++)
	{
		while (c[i]>9)
		{
			c[i]-=10;
			c[i+1]++;
		}
	}
	for (l3=l1+l2+3;l3;l3--)
	  if (c[l3]) break;
	for (int i=l3;i>=1;i--)
	  printf("%d",c[i]);
}


——by zhber,转载请注明来源
原文地址:https://www.cnblogs.com/zhber/p/4036057.html