A

A - Oulipo
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0


在刚开始用ci.get()一个个的输入字符,然后竟然超时了,然后就直接将一行输入,就ac了,可见每次单独的IO操作都会耗费一定的时间,而且耗费的时间还不短。
#include<iostream>
using namespace std;
char text[1000005];
char w[10005];
int nex[10005];
void findNext(int n)
{
    nex[0]=-1;
    int i=0;
    int k=-1;
    while(i<n)
    {
        if(-1==k || w[nex[i]]==w[i])
        {
            i++;
            k++;
            nex[i]=k;
        }
        else
        {
            k=nex[k];
        }
    }
}
int kmp(int n,int m)
{
    int i=0;
    int j=0;
    int num=0;
    while(i<n)
    {
        if(text[i]==w[j])
        {
            i++; j++;
        }
        else
        {
            j=nex[j];
        }
        if(j==m)
        {
            j=nex[j];
            num++;
        }
        if(-1==j)
        {
            j=0; i++;
        }
    }
    return num;
}
int main()
{
    int N;
    cin>>N;
    cin.get();
    int n=0,m=0;
    while(N--)
    {
        n=0;m=0;
        cin>>w;
        m=strlen(w);
        cin>>text;
        n=strlen(text);
        findNext(m);
        int num=kmp(n,m);
        cout<<num<<endl;
    }

}


原文地址:https://www.cnblogs.com/zhaoxinshanwei/p/3993826.html