hduoj1018 Big Number

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15789    Accepted Submission(s): 6977


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 
Sample Input
2 10 20
 
Sample Output
7 19
 
View Code
#include<stdio.h>
#include<math.h>
int main()
{
    int t,n,i;
    double d;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        d=0;
        for(i=1;i<=n;i++)
            d+=log10((double)(i));
        printf("%d\n",(int)(d+1));
    }
    return 0;
}
原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_07_1800.html