hduoj1097A hard puzzle

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18634    Accepted Submission(s): 6631


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 
Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 
Output
For each test case, you should output the a^b's last digit number.
 
Sample Input
7 66 8 800
 
Sample Output
9 6
View Code
#include <stdio.h>
int main()
{
    int a,b,t,i;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        a=a%10;
        b=b%4;
        t=1;
        if(b==0)
        {
            for(i=0;i<b+4;i++)
            {t=t*a%10;}
        }
            
            
        for(i=0;i<b;i++)
    {
        t=t*a%10;
    }
        printf("%d\n",t);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_06_05.html