hduoj1108最小公倍数

最小公倍数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20327    Accepted Submission(s): 11001


Problem Description
给定两个正整数,计算这两个数的最小公倍数。
 
Input
输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.
 
Output
对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。
 
Sample Input
10 14
 
Sample Output
70
 
Source
POJ
View Code
#include <stdio.h>
int main()
{
    int a,b,t,s;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        s=a*b;
        if(b>a)
        {
            t=a;
            a=b;
            b=t;
        }
        while(b!=0)
        {
            t=a%b;
            a=b;
            b=t;
            
        }printf("%d\n",s/a);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_05_290.html