hduoj1096A+B for InputOutput Practice (VIII)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55289    Accepted Submission(s): 16787


Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 
Sample Input
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 
Sample Output
10 15 6
View Code
#include <stdio.h>
int main()
{
    int n,a,b,sum,i,j;
    scanf("%d",&n);
    for(j=0;j<n;j++)
    {
        scanf("%d",&a);
        sum=0;
         for(i=0;i<a;i++)
         {
            scanf("%d",&b);
            sum+=b;
         }
        printf("%d\n",sum);
        if(j<n-1)
            printf("\n");
    }
    return 0;
}
 
原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_05_27.html