POJ 1611 记录节点数的并查集

The Suspects
Time Limit: 1000MS        Memory Limit: 20000K
Total Submissions: 33882        Accepted: 16428

Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output
For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4

1

1


题意:给定n个人数和m个组,下面m组的第一数是给出的这个组的已知的同学号,与0在一组的都是嫌疑人,且会传染,如第一组0和2在一起,第二组有2,则第二组全部是嫌疑人,问最后共有多少嫌疑人。

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 30000+10;

int f[maxn],sum[maxn];
 int n,m,k,tmp1,tmp2;

void init(){
     int i;
     for(i=0;i<n;i++){
        f[i]=i;
        sum[i]=1;//每个集合的数(树的节点)都是1 注意!从0开始!0也要算在传染病内,算在树内
     }
}

int find(int a){
    if(f[a]==a)
        return a;
        else
        {
            f[a]=find(f[a]);
            return f[a];
        }
    }
void merge(int v,int u){
     int f1,f2;
     f1=find(v);
     f2=find(u);

     if(f1!=f2){
        f[f2]=f1;
        sum[f1]+=sum[f2];//把旧树的节点的数目全部加到新树的节点数目
     }
     return ;
}

int main()
{
    //freopen("in.txt","r",stdin);
    while(cin>>n>>m&&n!=0){//宗人数和团体数

            init();

    while(m--){
            cin>>k;//每个团体的人数
            cin>>tmp1;//起始连接判断点
            k--;
            while(k--){
                cin>>tmp2;
                merge(tmp1,tmp2);//不是一棵树都连上去
            }
                }
        cout<<sum[find(0)]<<endl;
        }

    return 0;
}




原文地址:https://www.cnblogs.com/zhangmingzhao/p/7256749.html