POJ 2051 优先队列维护

Argus
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 11381   Accepted: 5506

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 

For the Argus, we use the following instruction to register a query: 
Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005


题意:Argus系统可以Register一个触发器,代号编码+周期,随着时间,给定k,Argus会根据时间的流逝和各个触发器的周期来响应,问前k个响应处理是哪些触发器的代号编码


思路:一半人看到这里肯定用整除取模的来解决吧,但是用优先队列来维护这个思路真的很巧妙

PS:POJ的G++识别不了bits/stdc++.h

//#include <bits/stdc++.h>
#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
struct Item {
    int Qnum;//编码
    int Period;//周期
    int time;
    //设定优先级,便于下面优先队列pop,相等条件下,比较Qnum,跟手写sort函数的cmp一样
    bool operator < (const Item& a) const {
        return time > a.time || (time == a.time && Qnum > a.Qnum);
    }
    };
int main()
{
    priority_queue<Item> pq;
    string s;
    while(cin>>s&&s!="#") {
            Item t;
        cin>>t.Qnum>>t.Period;
        t.time = t.Period;
        pq.push(t);
    }

    int k;
    cin>>k;
    while(k--) {
        Item r = pq.top();
        pq.pop();
        cout<<r.Qnum<<endl;
        r.time += r.Period;//加上它本来的周期再入队,更新触发器的下一个事件的时间
        pq.push(r);
    }
    return 0;
}



原文地址:https://www.cnblogs.com/zhangmingzhao/p/7256643.html