Hdu 1000 A + B Problem

A + B Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 668462    Accepted Submission(s): 208168

Problem Description

Calculate A + B.

Input

Each line will contain two integers A and B. Process to end of file.

Output

For each case, output A + B in one line.

Sample Input

1 1

Sample Output

2

#include<iostream> using namespace std; 

int main()

{ 

long long a,b;

 while(cin>>a>>b)

{ 

cout<<a+b<<endl;

 }

 return 0;

 }

Hdu 1001 Sum Problem

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 477885    Accepted Submission(s): 120768

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

#include<stdio.h>int main()
{
 int i,n,sum=0;
 while(scanf("%d",&n) != EOF) 
  { for(i=0;i<=n;i++)
     {sum=sum+i;}
      printf("%d

",sum);
      sum=0;
  }
 return 0;
}

  

Sample Input

1

100

Sample Output

1

5050

原文地址:https://www.cnblogs.com/zhangliu/p/7057766.html