POJ 2386 Lake Counting dfs

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 37384   Accepted: 18586

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
 
 
 
 
 
思路:扫描任意'W'的8个方向,全部替换成 '.' ,看能扫到几个'W' ,就是结果。
 
 
代码:
#include <iostream> 
using namespace std;
typedef long long ll;

char a[110][110];
    int m,n;
void dfs(int x ,int y){
    if(x < 0||x >= n||y < 0||y >= m){
        return;
    }
    a[x][y] = '.';
    
    for(int i = -1;i <= 1; i++){
        for(int j = -1;j <= 1; j++){
            if(a[x+i][y+j] == 'W'){
                dfs(x+i,y+j);
            }
        }
    }
    return;
}


int main() {
     int ans = 0;
 
  cin >> n >> m;
  for(int i = 0;i < n; i++){
      for(int j = 0;j < m; j++){
          cin >> a[i][j];
        }
    }
    
    for(int i = 0;i < n; i++){
        for(int j = 0;j < m; j++){
            if(a[i][j] == 'W'){
                dfs(i,j);
                ans++;
            }
        }
    }
    cout << ans << endl;
  return 0;
}
//  writen by zhangjiuding
原文地址:https://www.cnblogs.com/zhangjiuding/p/7663397.html