1104 Sum of Number Segments (20 分)有超时

1104 Sum of Number Segments (20 分)

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105​​. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

最后两个样例会超时
#include<iostream>
#include<vector>
#include<algorithm>
#include<map>
#include<set>
#include<cmath>
#include<climits>
#include<sstream>
#include<cstdio>
#include<string.h>
#include<unordered_map>
using namespace std;
long long int maxn=1000000;
int main()
{
    int n;
    scanf("%d",&n);
    double a;
    double sum[n+1];
    memset(sum,0,sizeof(sum));
    double result=0;
    for(int i=1;i<n+1;i++)
    {
        scanf("%lf",&a);
        sum[i]=sum[i-1]+a;
        result+=sum[i];
    }
    for(int i=1;i<n;i++)
    {
        for(int j=i+1;j<n+1;j++)
        {
            result+=sum[j]-sum[i];
            //cout<<sum[j]-sum[i]<<endl;
        }
    }
    printf("%.2f",result);

    return 0;
}
 
原文地址:https://www.cnblogs.com/zhanghaijie/p/10346794.html