1038. Recover the Smallest Number (30)

题目例如以下:

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

最初看到这个题目。我先想到的是桶排序,设置0到9号桶。先依照最高位把数字分别装入桶内,然后针对不同的桶,依照从高位优先排序,当中数字小的相应的字符串小,假设位数不同而且前面长的字符串和短的字符串前面全然一致,则看长字符串后面的部分和桶序号哪个大,比桶序号大的说明这个数应该往后放,由于桶内的全部数字都是以桶序号开头。假设把这样一个数字放到前面,则会出现新拼接的字符串命名能够以桶序号开头却以一个比桶序号大的数开头,详细实现为先按上面的规则定义字符串比較函数。然后对每一个桶进行插入排序。须要注意的问题是第一个数的选取。应该选取桶0中除去前导0后数字最小的,把它抛开,再对其它数进行上面的排序,最后从桶0開始输出到最后一个桶。我后来实现了这个算法,可是有一些BUG没有解决,仅仅能得到20分


后来通过网上查阅资料发现我把这个题想复杂了,事实上仅仅须要比較字符串然后排序就可以。对于两个字符串a和b,比較ab和ba的大小,为了让数字最小,要让最小的字符串在前面,也就是ab < ba是我们所期望的,因此仅仅须要把全部字符串依照这个规则排序就可以。

须要注意的是,输出时第一个数不能有前导0,假设全部数字都是0。我们仅仅能输出一个0。

为了这两个需求,我使用了stringstream把字符串转为数字。

对于第一个数字,仅仅须要直接转为数字输出就可以。

为了推断是否所有数字都是0,找到最大的字符串。也就是排序后的最后一个,看它转为数字是否是0,假设是,最大的都是0,说明所有都是0,这时候直接输出一个0然后返回。

#include <iostream>
#include <vector>
#include <string>
#include <string.h>
#include <algorithm>
#include <sstream>

using namespace std;

int compare(string a, string b){
    string ab = a + b;
    string ba = b + a;
    return ab < ba;
}

int main(){

    int N;
    vector<string> nums;
    string buffer;
    cin >> N;
    for(int i = 0; i < N; i++){
        cin >> buffer;
        nums.push_back(buffer);
    }
    sort(nums.begin(),nums.end(),compare);
    stringstream ss;
    int num;

    // 排除全0情况。先找最大的字符串看是否为0
    ss << nums[nums.size()-1];
    ss >> num;
    if(num == 0){
        cout << 0 << endl;
        return 0;
    }
    // 注意清除原来的输入
    ss.clear();

    ss << nums[0];
    ss >> num;
    cout << num;
    for(int i = 1; i < nums.size(); i++){
        cout << nums[i];
    }
    cout << endl;
}


原文地址:https://www.cnblogs.com/zfyouxi/p/5127088.html