Bone Collector(01背包)

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14
题目大意:
给定n,v分别代表n个骨头,体积为v的背包,接下来n个数字代表n个骨头的价值,再接下来n个数字代表n个骨头的体积。
01背包模板
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int w[1005],v[1005],dp[1005];
int n,m;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(dp,0,sizeof dp);
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            cin>>v[i];
        for(int i=1;i<=n;i++)
            cin>>w[i];
        for(int i=1;i<=n;i++)
            for(int j=m;j>=w[i];j--)
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        cout<<dp[m]<<'
';
    }
    return 0;
}


 
原文地址:https://www.cnblogs.com/zdragon1104/p/9189020.html