栈实现括号

           括号配对问题

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
 
描述
现在,有一行括号序列,请你检查这行括号是否配对。
 
输入
第一行输入一个数N(0<N<=100),表示有N组测试数据。后面的N行输入多组输入数据,每组输入数据都是一个字符串S(S的长度小于10000,且S不是空串),测试数据组数少于5组。数据保证S中只含有"[","]","(",")"四种字符
输出
每组输入数据的输出占一行,如果该字符串中所含的括号是配对的,则输出Yes,如果不配对则输出No
样例输入
3
[(])
(])
([[]()])
样例输出
No
No
Yes

#include<iostream>
#include<stack>
#include<vector>
using namespace std;
void main()
{
char str[100],ch;
int n;
stack<char,vector<char>>s;
cin>>n;
while(n--)
{
int i=0;
cin>>str;
while(i<strlen(str))
{
if((str[i]=='(')||(str[i]=='[')) s.push(str[i++]);
else if(str[i]==')')
{
i++;
if(s.top()=='(') s.pop();
else break;
}
else
{
i++;
if(s.top()=='[') s.pop();
else break;
}
}
cout<<"i== "<<i<<endl;
cout<<"strlen(str)== "<<strlen(str)<<endl;
if(i==strlen(str)) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
}

原文地址:https://www.cnblogs.com/zdblog/p/3631298.html