试题 算法训练 数的统计 -> map set基础练习

问题描述
  在一个有限的正整数序列中,有些数会多次重复出现在这个序列中。
  如序列:3,1,2,1,5,1,2。其中1就出现3次,2出现2次,3出现1 次,5出现1次。
  你的任务是对于给定的正整数序列,从小到大依次输出序列中出现的数及出现的次数。
输入格式
  第一行正整数n,表示给定序列中正整数的个数。
  第二行是n 个用空格隔开的正整数x,代表给定的序列。
输出格式
  若干行,每行两个用一个空格隔开的数,第一个是数列中出现的数,第二个是该数在序列中出现的次数。
样例输入
12
8 2 8 2 2 11 1 1 8 1 13 13
样例输出
1 3
2 3
8 3
11 1
13 2
数据规模和约定
  数据:n<=1000;0<x<=1000,000。
思路:基础函数使用
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <stack>
#include <cstring>
#include <iomanip>
#include <cmath>
#include <map>
#include <set>

using namespace std;

const int N = 1010;

int n;
int a[N];

int main()
{
    cin >> n;
    map<int, int> mp;
    set<int> s;
    for (int i = 1; i <= n; i ++ )
    {
        int x;
        cin >> x;
        mp[x] ++ ;
        s.insert(x);
    }
    for (set<int>::iterator it = s.begin(); it != s.end(); it ++ )
    {
        cout << *it << ' ' << mp[*it] << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/zbx2000/p/12759609.html