果然状态不好就不要去写代码//。。。。 不一样的广搜 1728

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22160 Accepted Submission(s): 5392


Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 
Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。
 
Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 
Sample Input
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 
Sample Output
no yes
  
这里路径的最短是要让转弯的次数最少而且  这里也不可以使用优先队列。。 如果使用了转弯次数的优先的话   
#include <iostream>
#include <queue>
using namespace std;

const int M = 111;

int n, m;
int max_turn;
int star_x, star_y, end_x, end_y;
char g[M][M];
bool vis[M][M];
int dir[4][2] = {0, 1, 1, 0, 0, -1, -1, 0};
//右,下,左,上


struct Node
{
    int x, y;
    int turn_num;

};

int Bfs()
{
    queue <Node> q;
    Node q1;
    q1.x = star_x;
    q1.y = star_y;
    q1.turn_num = -1;
    q.push(q1);
    vis[star_x][star_y] = 1;

    while (!q.empty())
    {
        Node q2 = q.front();
        q.pop();

        if (q2.x == end_x && q2.y == end_y && q2.turn_num <= max_turn)
        {
            return 1;
        }

        q1.turn_num = q2.turn_num + 1;
        
        for (int i = 0; i < 4; i++)
        {
            q1.x = q2.x + dir[i][0];
            q1.y = q2.y + dir[i][1];
            while (q1.x >= 1 && q1.x <= n && q1.y >= 1 && q1.y <= m && g[q1.x][q1.y] == '.'/* && !vis[q1.x][q1.y]*/)//**********
            {
                if (!vis[q1.x][q1.y])//*********************************
                {
                q.push(q1);
                vis[q1.x][q1.y] = 1;
                }
                q1.x += dir[i][0];
                q1.y += dir[i][1];
            }
        }
    
    }
    return 0;
}

int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &m);
        for (int i = 1; i <= n; i++)
        {
            for (int j = 1; j <= m; j++)
            {
                scanf(" %c", &g[i][j]);
            }
        }

        scanf("%d%d%d%d%d", &max_turn, &star_y, &star_x, &end_y, &end_x);

        memset(vis, 0, sizeof(vis));



        if (Bfs())
        {
            puts("yes");
        }
        else
        {
            puts("no");
        }
    }
    return 0;
}
 
 
原文地址:https://www.cnblogs.com/z1141000271/p/5531287.html