nyist 233 Sort it

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
输入
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
输出
For each case, output the minimum times need to sort it in ascending order on a single line.
样例输入
3
1 2 3
4 
4 3 2 1 
样例输出
0
6

http://acm.nyist.net/JudgeOnline/problem.php?pid=233
就是计算选择排序交换的次数


#include <stdio.h>

int a[1005];
int main()
{
    int  m;
    while( scanf("%d",&m) != EOF)
    {

        int i = 0;
        int j = 0;
        int k = 0;

        for(i = 0; i < m; i++)
            scanf("%d",&a[i]);

        for(i = 0; i < m; i++)
                for(j = i+1; j < m; j++)
                    if(a[i]>a[j])
                    {
                        int b = a[i];
                        a[i] = a[j];
                        a[j] = b;
                        k++;
                    }

          printf("%d",k);
          printf("\n");
    }
    return 0;
}




原文地址:https://www.cnblogs.com/yyroom/p/2963358.html