HDU 1754 I Hate It [线段树]

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1754

题目:

                                     I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 109625    Accepted Submission(s): 41003

Problem Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input 

5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5

Sample Output

5 6 5 9

Hint

Huge input,the C function scanf() will work better than cin

思路:接触的第一个线段树,有点懵逼,就是简单的单点更新查找最大值,注释放在代码里;

代码:

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
const int MAXNODE=1<<19;
const int MAXN=2e6+10;
int max(int a,int b)
{
	return a>b?a:b;
}
struct Node
{
	int left,right;//线段树该点所代表的区间 
	int value;//线段树该点的权值 ,该题是指最大值 
}node[MAXNODE];
int father[MAXN];
void BuildTree(int i,int left,int right)//以区间【left,right】建立一个i为祖先的线段树,也是第i个节点 
{
	node[i].left=left;
	node[i].right=right;
	node[i].value=0;
	if(left==right)//区间长度为零时,此时为叶节点 ,结束递归 
	{
		father[left]=i;
		return;
	}
	//对父节点的区间进行二分之后进行二分 
	BuildTree(i<<1,left,(int)floor((left+right)/2.0));
	BuildTree((i<<1)+1,(int)ceil((left+right)/2.0),right);
}
void UpdateTree(int ri)//从下往上更新 
{
	if(ri==1) return;//找到祖先节点 
	int fi=ri/2;//父节点 
	int a=node[fi<<1].value;
	int b=node[(fi<<1)+1].value;
	node[fi].value=max(a,b);//更新这个父节点 
	UpdateTree(ri/2);//递归更新,从下往上找 
}
int Max;
void Query(int i,int l,int r)//从最顶端查找 
{
	if(node[i].left==l&&node[i].right==r)//要查找的区间与目标区间重合 
	{
		Max=max(Max,node[i].value);
		return;
	}
	i=i<<1;//查找左孩子 
	if(l<=node[i].right)
	{
		//如果查找的区间全部在目标区间中继续查找 
		if(r<=node[i].right)
		{
			Query(i,l,r);
		}
		else
		//开始这里很迷,其实仔细一想只能这样,若右端点为l的话,目标区间最大才为node[i].right,这样就越界了 
		{
			Query(i,l,node[i].right);
		}
	}
	i++;//右孩子 
	//道理同左孩子 
	if(r>=node[i].left)
	{
		if(l>=node[i].left)
		{
			Query(i,l,r); 
		}
		else
			Query(i,node[i].left,r);
	}
}
int main()
{
	int n,m,g;
	std::ios::sync_with_stdio(false);
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		BuildTree(1,1,n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&g);
			node[father[i]].value=g;
			UpdateTree(father[i]);
		}
		char op;
		int a,b;
		while(m--)
		{
			cin>>op>>a>>b;
			if(op=='Q')
			{
				Max=0;
				Query(1,a,b);
				cout<<Max<<endl;
			}
			else
			{
				node[father[a]].value=b;
				UpdateTree(father[a]);
			}	
		}
	}
	return 0;
}
原文地址:https://www.cnblogs.com/yyaoling/p/12260440.html