POJ2586 -- Y2K Accounting Bug

Y2K Accounting Bug
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16395   Accepted: 8251

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source

 
题意: 
有一个公司由于某个病毒使公司赢亏数据丢失,但该公司每月的 赢亏是一个定数,要么一个月赢利s,要么一月亏d。现在ACM只知道该公司每五个月有一个赢亏报表,而且每次报表赢利情况都为亏。在一年中这样的报表总共有8次(1到5,2到6,…,8到12),现在要编一个程序确定当赢s和亏d给出,并满足每张报表为亏的情况下,全年公司最高可赢利多少,若存在,则输出盈利额,若不存在,输出"Deficit"。
 
题意分析:
公司每五个月报一次表,都为亏损,说明12个月中任意连续五个月总计为亏损。
因为让求全年公司最高可盈利多少,所以在满足连续五个月总计为亏损的条件下,应该尽可能的盈利。即为贪心算法。
 
解题思路:
首先考虑第一个月,赢利s,亏d
若s>=4d,即有四个月亏损一个月盈利无法满足连续五个月总计为亏损的条件,所以必须要连续五个月全都亏损,这样全年不会有盈利。Deficit
 
s<4d && 2s>=3d,即有三个月亏损两个月盈利无法满足连续五个月总计为亏损的条件,连续五个月中,最多有一个月为盈利,所以12个月的状态应为sddddsddddsd,全年的利润为3s-9d
 
2s<3d && 3s>=2d,即有两个月亏损三个月盈利无法满足连续五个月总计为亏损的条件,连续五个月中,最多有2个月为盈利,所以12个月的状态为ssdddssdddss,全年的利润为6s-6d
 
3s<2d && 4s>=d,连续五个月中,最多有3个月盈利,所以12个月的状态为sssddsssddss,全年的利润为8s-4d
 
4s<d,即连续5个月中,有四个月盈利一个月亏损,满足连续五个月总计亏损的条件,最多有4个月盈利,所以12个月状态为ssssdssssdss,全年的利润为10s-2d
 
不能连续5个月盈利。
 
 
#include<iostream>
using namespace std;
int main()
{
    int s,d;
    while(cin>>s>>d)
    {
        int total;
        if(s >= 4*d)
        {
            total = -1;
        }else if(2*s>=3*d)
        {
            total = 3*s - 9*d;
        }else if(3*s>=2*d)
        {
            total = 6*s - 6*d;
        }else if(4*s>=d)
        {
            total = 8*s-4*d;
        }else{
            total = 10*s-2*d;
        }

        if(total > 0)
        {
            cout<<total<<endl;
        }else{
            cout<<"Deficit"<<endl;
        }

    }

    return 0;
}

  

 
原文地址:https://www.cnblogs.com/yxh-amysear/p/8410197.html