【学习笔记】〖九度OJ〗题目1464:Hello World for U

题目1464:Hello World for U

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:2475

解决:678

题目描述:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d
e     l
l      r
lowo


That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:

There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:

For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com
样例输出:
h   !
e   d
l   l
lowor
a    m
c    o
.    c
jobdu.

/*题目1464:Hello World for U*/

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

int main()
{
	freopen("in.in", "r", stdin);
	freopen("out.out","w", stdout);

	//输入部分
	char input[81];
	while(cin >> input)
	{
	string s = input;
	int len = s.length();

	//计算部分
	int n1,n2, n3,i,j;

	n1 = n3 =(len + 2) / 3 -1;
	n2 = len - n1 - n3;
	string left,right, bottom;

	left = s.substr(0,n1);
	right = s.substr(len-n3,n3);
	bottom = s.substr(n1,n2);
	reverse(right.begin(),right.end());
	for (i=0; i<n1; i++)
	{
		cout << left[i];
		for (j=0; j<n2-2; j++)
			cout << " ";
		cout << right[i] << endl;
	}
	cout << bottom << endl;
	}
	return 0;
}




原文地址:https://www.cnblogs.com/ymjia/p/3590308.html