A

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
 
差分约束
如若一个系统由n个变量和m个不等式组成,并且这m个不等式对应的系数矩阵中每一行有且仅有一个1和-1,其它的都为0,这样的系统称为差分约束( difference constraints )系统
 
该题就是利用差分约束把不等式化成有向图,再利用Bellman算法求解最短路就可以得到最大长度
 
#include<iostream>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int maxn=2e4+10;
struct node
{
    int from,to,cost;
}edge[maxn];
int e=0;
ll bd[maxn];
int n,ml,md;

void bel(int s)
{
    fill(bd,bd+maxn,inf);
    bd[s]=0;
    while(true)
    {
        bool updated=false;
        for(int i=0;i<e;i++)
        {
            node e= edge[i];
            if(bd[e.from]!=inf&&bd[e.to]>bd[e.from]+e.cost)
            {
                bd[e.to]=bd[e.from]+e.cost;
                updated=true;
            }
        }
        if(!updated) break;
    }
}

bool find()
{
    fill(bd,bd+maxn,0);
    for(int i=0;i<n;i++)
    { 
       for(int j=0;j<e;j++)
       {
            node e=edge[j];
            if(bd[e.to]>bd[e.from]+e.cost)
            {
                bd[e.to]=bd[e.from]+e.cost;
                if(i==n-1)  return true;
         }
       }
    } 
    return false;
}
int main()
{
    int a,b,d;
    cin>>n>>ml>>md;
    for(int i=0;i<ml;i++)
    { 
      cin>>a>>b>>d;
      edge[e].from=a;
      edge[e].to=b;
      edge[e++].cost=d;
    }
    for(int j=0;j<md;j++)
    { 
      cin>>a>>b>>d;
      edge[e].from=b;
      edge[e].to=a;
      edge[e++].cost=-d;
    }
    bool is=find();
    if(is)
    {
        cout<<-1<<endl;
        return 0;
    }
    bel(1);
    if(bd[n]==inf)
    {
        cout<<-2<<endl;
    }
    else
    {
        cout<<bd[n]<<endl;
    }
    return 0;
} 

原文地址:https://www.cnblogs.com/ylrwj/p/11794789.html